Monitoring
Intermittent issue resolved. Monitoring.
Identified
Due to intermittent issues of a downstream provider, we’re experiencing issues with payments processing that result in some of the payments incorrectly identified as failed. Any incorrectly-identified-as-failed payments will be refunded.